Question

Swannview Plus app not working properly


I’ve been having a problem with my Swannview Plus app for a very long time now. It used to work good. Unfortunately now when I try to open the cameras they take forever to open. Sometimes it takes almost 10 seconds for video feed to show up on the app. Then when I try to scroll over to the next four videos they never show up. It just shows that little spinning thinking wheel and fails to connect. Sometimes when I open the app and scroll over the second 4 cameras right away I can get the second 4 cameras to open. The app is horrible! I can’t virw all my cameras when I want to. I’m seriously thinking about buying another brand because the Swannview Plus app just doesn’t work for me. I’m hoping that Swann can help me out ASAP!

16 replies

Yep I'm having the same issue. Is there going to be a fix for this or do I have to look elsewhere ?
Userlevel 4
Badge +2
Hi Ottoman12,

Welcome to the community!

Let me ask, have you tried other phones and compare the results? Not only network could cause the issue, the phone is one factor too. What phone are you using and to which network are you connected when you're searching for recordings?
I’m using the iPhone X. It’s my only phone. My ATT WiFi network is fast so it shouldn’t take a long time for my videos to open up on the Swannview Plus app. Like I said when I first got this system it worked just fine, now it’s horrible! I’m really thinking about buying a different brand security system if I can’t get this thing to work correctly.
Userlevel 4
Badge +2
We need more information to properly isolate this case:
  1. Model number of your Swann recorder.
  2. Number of cameras connected.
  3. Using a computer connected to the same router where your recorder is connected, go to http://www.speedtest.net/ and run some test. Provide the Ping, Download, and Upload results
  4. Using your phone connected to your ATT network which you said was working fine before, download SpeedTest app and run a test as well. Provide the same information afterwards.
  5. On you recorder, access the Menu and go to Record > Parameters then click Substream at the top. Provide the numbers shown on Video Quality. Change the channel (called Camera) above and go to each channel. If Video Quality differs, please indicate all on your next response; if not, you can just provide one.

I have 11 cameras. All 11 cameras are at resolution 352*240(CIF), 15fps, and video quality of low/128. On my computer I ran a speed test with a result of Ping 8ms, upload 122.20 Mbps, and download 122.20 Mbps. On my iPhone X it was Ping 7, download 117 Mbps, and upload 121 Mbps.
Userlevel 4
Badge +2
Just to make sure, the speed mentioned using the computer, did it really show the same speed? May I know what plan did you get and from which carrier? And on your phone, is that the speed using you mobile data and not WiFi?

If all information provided were correct, then I may need to know the firmware version your NVR is running. You can get it when you access the Menu and go to Maintenance > System Info > Device Info.
I got a high speed plan from AT&T. My NVR firmware is V3.0.8, Build 141009
Userlevel 4
Badge +2
Forgot to ask, can you double check the model number on the same page where you got the firmware and reply here?

Take note if it shows 7090 or 7095 as you need to download the correct firmware. Follow the steps below on how to do the update:
http://support.swann.com/customer/en/portal/articles/2544490-nvrx-7090-7095-firmware-release-all-channel-variants-
Under model it says 16ch 3MP NVR
It does not say 7090 or 7095 next to model. It says 16ch 3 MP NVR. If you need my serial number it’s 1620141016AARR093856835WCVU
Userlevel 4
Badge +2
I was able to verify that this is a 7090 model. Go ahead and try to update the unit. By the way, did you changed plans for your internet? If so, did the issue started to happen after that?
I was able successfully update the NVR, and now I’m finally able to view all my cameras on my phone again. Thank you soooooooo much! You deserve a raise! 😊👍🏼
Userlevel 4
Badge +2
That's good to know! 😎
So I have another question. I have a couple of Samsung IP Smartcams that I bought at Costco a long time ago. I used to be able to connect those cameras wirelessly to my NVR. I was able to view those two cameras through the NVR and record the video by entering their IP address. Then one day they stopped connecting to my NVR. Any idea on how to reconnect them? I’ve tried to reconnect them but have been unsuccessful.
Userlevel 4
Badge +2
I'm afraid that knowing how your Samsung cameras work is beyond my support but all I can recommend is swapping it with other working camera (basically, more on trial and error on physical connections).

Reply