Question

Homesafe view, won't connect to dvr-4780 unless on WiFi???

  • 29 December 2017
  • 35 replies
  • 27709 views


Show first post

35 replies

Thanks @snow I tried this removed app re added too still not working thank you anyway
On the dvr, disable the alert function
Have you tried a different app,
Only tried the homesafe view app wasn’t sure other ones were compatable do any of them work? Thanks
I did disable the alert on the dvr thanks
Swann does many different apps, give it a go, try the swann view link
Will do thanks
muz wrote:
I tried all of the above and still didn't have any luck, found;

If you add device/DVR when connected to the same network you will ONLY be able to view your cameras when connected to the same network going forward.

The trick is to make sure when adding your DVR to the HomeSafe View app, by scanning UID code, your mobile should NOT be connected to the same network/WiFi (turn off WiFi on mobile) as the DVR.

1.Turn off wifi on mobile device
2.Go to 'Device' in app menu
3.Press + in top right corner
4.Press Manual Adding
5.Press bar code symbol next to Device ID and scan UID sticker on your DVR
6.Make sure correct user name and password are used
7.Press save in top right corner

Now the connection should work both when remotely and when on local network also.

(did find that when reopening the app that it would take some time for the app to connect to the DVR remotely, found if I went into the device and selected my DVR and then pressed save again that the app would connect again)

This solved the issue for me as well 👍
Good morning John - Yes but my verizon S8 doesn't have a setting for 3/4G networks. I did make sure the 'mobile data' within the S8 app settings were on. But I think I may have resolved the issue. There were some setting conflicts within my router with the DVR and some devices. Also, per the support instructions on the Swann website I did setup and test the DVR static ip and port forwarding. Although the recommended use of IP 200 didn't work for me. I'm doing a test for several days to insure it is stable before I begin the installation. Thanks for the suggestion. Joe
May I ask which settings I’m your router? I’m having the same issue
I tried all of the above and still didn't have any luck, found;

If you add device/DVR when connected to the same network you will ONLY be able to view your cameras when connected to the same network going forward.

The trick is to make sure when adding your DVR to the HomeSafe View app, by scanning UID code, your mobile should NOT be connected to the same network/WiFi (turn off WiFi on mobile) as the DVR.

1.Turn off wifi on mobile device
2.Go to 'Device' in app menu
3.Press + in top right corner
4.Press Manual Adding
5.Press bar code symbol next to Device ID and scan UID sticker on your DVR
6.Make sure correct user name and password are used
7.Press save in top right corner

Now the connection should work both when remotely and when on local network also.

(did find that when reopening the app that it would take some time for the app to connect to the DVR remotely, found if I went into the device and selected my DVR and then pressed save again that the app would connect again)



This ended up working for me to connect to the DVR without the wifi on my phone being on. I hope this can help anyone else who was struggling as my fiancee and i had the same issue and now is working correctly.

Reply