Question

Push notification stopped working.


I have recently purchased model SWDVK-845804. At least I think that’s the model. It’s the 8 channel thermal sensing security system.

All was working ok, but I reconnected some cameras and the app got confused so I reinstalled it. Now push notifications have stopped. All is set up on the main settings ok, but when I check the alarm settings on the app the push notifications are off if I switch them on I get the error message below.


I have reinstalled the app but to no avail. I have also installed the app on my iPad and get the same issue which makes me think it’s not my phone. Any ideas?


Thanks

Martin

18 replies

I had something similar on my iPad but I couldn't see the entire message (could only see the word NOTICE). Turns out I'd disabled Notifications on the iPad. Try turning these back on; Settings -> Notifications -> HomeSafe View (assuming that's the app you're using)

Thanks. That doesn’t seem to be the issue. My phone is the main problem.
I think your right, seeing exactly the same error on two other iPhones. Will continue to t’shoot. I’m assuming you’re still having the same issue?
Userlevel 4
Badge +2
Hi everyone,

Please check this article as it may help you enable the push notification:
http://support.swann.com/customer/en/portal/articles/2921151

If this didn't help, kindly provide the firmware version and model number of your unit.
Same here I have checked all the notification settings on iPad and iPhone and the dvr.

When end I switch on the alarm switch it just toggles back to off and says ”notice” as in the above post ?

Folled the link above too...
Just tried this via android and it is working.

Iphone and iPad still not. All settings look correct. . .? And updated iOS

on an 847804 8 channel with 3mp cameras seem strange ..
Thx for the link JohnL; the stamps he thing is that we’ve got 4 iPhones and an iPad. Works on my phone and the iPad but not other the devices. It’s something to do with the Notifications setting on the phone itself. Sounds like Swann’s Support need to troubleshoot this and issue an app update!

im using supported hardware - 4575 and the 1080MSB cameras.
Userlevel 4
Badge +2
Hi everyone,

An update is on the works for iOS users, kindly wait for an app update soon. No ETA at the moment.
Hi John

Every thing was set up fine. It did work for a couple of days. I've also got my mate to try and connect on his iPhone and I'm getting the same message.

My system model is: DVR8-4575

Firmware: V7.1.0-20170908

I've noticed that when I try to check for an update, I'm getting a message to say if failed and to check my connections. Email notifications are working fine as is the Homeview app apart from push notifications. So I'm assuming I my network connections must be ok. But I don't know, its all very confusing.
Looks like v1.1.2 released today has resolved the issue!
Looks like it may have. I can switch the notification button on on the phone now. I shall test it out. Thanks for posting.
I think fixing one issue has now introduced another bug. The 3 Users in my household who were having the issue are now able to turn the alerts on, but when they turn it back off in the HomeSafe View app, they continue to receive notifications.

Works as expected on my iPhone and iPad.

Can you feed this back JohnL
Userlevel 4
Badge +2
Hi Sahins,

What are their phones? Have you tried closing the app and by that, I mean not just going back to your homescreen. Like on Android, you can press your Recents button then swipe to the left to close the app.
This update fixed my IPhone until today. I got home from work and the notifications weren’t working on my phone but we’re on my iPad. Tried a few things to get the notifications working but nothing worked so I uninstalled the app and reinstalled. Now I get push unknown error again. Has the old version been put back on iTunes?
Userlevel 4
Badge +2
Hi Jammarsh,

We made some testing on our end and it's working on our iPad mini running iOS 11.3 and the latest HomeSafe View app v1.1.2. Have you read and followed carefully this article:
Enabling Push notification on Thermal Sensing recorders using the HomeSafe View app
Thanks John. I have it working again. I managed to get it enabled again by uninstalling the app again and the next time it let me enable notifications. I still wasn’t getting any notifications though until later that night when about a hundred notifications came through in about 5 seconds. Since then it has worked fine. Must just have been some network problem somewhere so the push notifications didn’t come for a few hours. Thanks for the reply. I should have replied to say everything was ok earlier
Userlevel 4
Badge +2
That is fine, glad to know that it's now working.

Reply