Question

Dvr stuck on loading screen


We have a dvr 1080p 8 channel, 6 camera hooked up was operating fine since 2015, no changes to system, wifi etc and it’s now stuck on loading screen. It’s not a power cord issue.

Replaced the hard drive and no change still showing loading.

has anyone found a fix for this? It’s not under warranty so SWann was no help, told us to replace the hard drive. OBviously that’s not the problem, where do I get a replacement dvr that will work with this?

Can i I force a update of the firmware, or software?


12 replies

Hi @Dhairsine

Welcome to the community!

Firmware update is unlikely an option at this moment. Things we consider when it comes to a DVR or NVR stuck on a loading page are the following:

  • Power adapter - you may need to test the NVR's power adapter if it is getting a 48v2a output using a volt meter tester. You may also try connecting the NVR to a different outlet.
  • HDMI cable/connection - you can try to re-seat the cable or connect it to a different HDMI port on your TV (if it has multiple HDMI ports).
  • Hard drive - The hard drive of the NVR might be failing already.
If above factors have been isolated already. I would suggest you contact our tech support so we can rectify where the issue is coming from.
Have the same issue here.
Have changed and checked voltages on different power adaptors. When I power up the dvr, it just stops at the Swan logo, and will not load the menu.
I have had the hard drive checked and all is good. Have contacted tech support and the only answer is, as they follow their script, change your power adaptor!
I have done all of this. I suspect the firmware is corrupt, is there any way I can reload this when not being able to get to the menu screen.
I forgot to mention , my unit is a DVR-4575
I am having the same issue. Stuck on loading screen and wont boot up. I am hearing a buzzing and clicking sound from inside the unit.
Gav, sounds like the same problem I was having. Luckily mine was about 1 month inside the warranty period. I returned it for repair, and they replaced the unit. I never found out what the problem was.
If yours is out of warranty you would have to weigh up the cost of repair or replacement.
Mine will be out of warranty. I intend on changing the hard drive first as this could be a cheaper fix if thats the cause. If that doesn't fix it then next stage is to get a new dvr and camera system using the current wiring in place. I can sell the swann cameras to recoup some cost.
I am having the same issue. I added two more cameras, but accidentally hit the power button while plugging the cameras into the dvr and now it will not load. SRDVR 164500H S/NO 2867410150178
Solved. My unit was not booting whatsoever and produced a beeping and sometimes a clicking noise. I had removed the hard drive in a hope to buy a new drive as i thought the clicking was the needle on hdd. Before going to get the new hard drive i put everything back together. I took the unit, cable and camera etc to a local electronic shop. He had a camera system set up on display. Plugged my unit in and voilla! It worked! I was confused. He advised that the dvt unit wasn't getting enough power to boot up which was causing the noise. Originally i had one 12v plug and an 8 way splitter powering 5 cameras and the dvr unit itself. He told me it wasnt enough to power the dvr hdd, networking, and five cameras with the infrared lights. He advised one plug standalone for the dvr and two more plugs, one to two and one to three. When i got home i set it up paying particular attention to what output rating each plug was giving the higher rating to the dvr. Allnis working fine now.
I have the same issue and had it twice!

I recently bought a house with the DVR8-4575 and when I moved in it was just stuck on the loading screen. I did all troubleshooting and even contacted tech support - changing power adapters everything.

Eventually since we didn't have warranty on it I replaced it and bought a brand new DVR8-4575. Which worked fine for the last 7 months.

Yesterday all of a sudden it was back on the loading screen (see attached image). I've checked all the power adapters everything, and haven't changed anything.

Steps I have tried:
  • Disconnect the cameras.
  • Disconnect the LAN/Ethernet cable.
  • Leave the mouse and monitor connected.
  • Reboot the NVR afterwards. No luck, still stuck on the blue screen
  • Power adapter - you may need to test the NVR's power adapter if it is getting a 48v2a output using a volt meter tester. You may also try connecting the NVR to a different outlet. Power Adapter and outlet have not changed in 7 months...... and was working fine
  • HDMI cable/connection - you can try to re-seat the cable or connect it to a different HDMI port on your TV (if it has multiple HDMI ports). Cable and screen have been working fine for 7 months

I don't get how:
  1. It suddenly stopped working
  2. There's absolutely no way to fix this without replacing the actual unit
Swann - what is wrong with this model?!?

This is the DVR - the HDD light does not flash.

Update for those with the same issue: I called Swann since my unit is under warranty and they've advised to RMA it....

Reply